Help regarding USACO Guide Login

Hello, I have been trying to log in to USACO Guide for a long time but it just doesn’t work. Every time I try to log in, it is just stuck at this:

It doesn’t load even after 5-10 minutes. I have tried using different browsers, different laptop, as well as different WiFi network, but the problem persists. The feature does however work on my phone.
Also all permissions for the USACO Guide site are set to “allowed” and I’ve even tried allowing all permissions for all sites.
Could anyone please help me through this issue?

check the browser console. are there any error messages?

It does not show any error messages, but there is a “possible improvement message” showing:

Audit usage of navigator.userAgent, navigator.appVersion, and navigator.platform

Is this relevant?

seems unlikely.

where are you located? some people got this working after using a VPN to the united States…

India. But I wasn’t using a VPN. Anyways, it started working yesterday, which was probably the first time I tried since I enabled my antivirus again. (I had disabled it earlier for this issue only). Thanks for your support anyways